Screwed on E40D rebuild??? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 02-08-2012, 10:35 AM Thread Starter
Join Date: Mar 2011
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Screwed on E40D rebuild???

So I just got my truck back 4 days ago from paying for an illegid complete rebuild.
As I was driving home it starts to make this squealing/whistling noise that sounds like its coming from the fire wall area. Took it back in the next morning and it wouldn't make the noise for them. Aarrgghh!! Still makes the noise, usually after its been drivin for a while.
Yesterday at about 2000 rpm's and 70 mph it starts to vibrate and feel like it didn't have any more to give. Checks the connections at the valve covers and will pick up a fuel filter and CPS today because I haven't touched those since buying the truck.
The 2nd to 3rd shift still feels premature some times and my fear is that I got taken by the trams shop. What do you guys think? Could the vibration be the tranny?.
Thanks guys for all your help and input!

Sent from my Autoguide iPhone app
Jeter is offline  
Sponsored Links
post #2 of 3 Old 02-08-2012, 10:54 AM
Compression Ignition Addict
Join Date: Dec 2011
Location: Northern Arizona
Posts: 2,146
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 4 reviews
If it never vibrated or made noise before I would take it back to the shop and drive it with one of them until they hear noise or feel vibration. Only other thing that comes to mind is turbo making noise but not likely.

97 F250 Xlt, built E4od, D60 swap, Baby swamps, tunes by Dp
1.0 turbo housing, 203* t-stat, diy 6637, 4" exhaust
Diy intercooled, 6.0 fan, Diy 140v Idm, Isspro Ev gauges
On board air,E-fuel, 5" lift on 35's
320000 miles
1Dieselman is offline  
post #3 of 3 Old 02-08-2012, 11:41 AM Rookie
Join Date: Jan 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hey Jeter
I'm new to this fourm, in fact this is my first post but after reading your post it reminded me about a problem i had with my 96 cc 4x4 at the same time the trans went out. I was hearing a loud squeal with a slight vibration at 30-40 mph intermittent. Even after i got my truck back from the shop the squeal and vibration would come and go. It ended up being a bad drive line center support bearing. You may want to check the play in the rubber bushing, there should be very little play. Not saying that's what wrong in your case, but just a thought.
psd 4 me is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome