OD Light flashing & truck dies in reverse - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 08-18-2011, 07:17 PM Thread Starter
Member
 
Join Date: Dec 2009
Location: Memphis
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
OD Light flashing & truck dies in reverse

I have a 97' F-250 and my overdrive light on the shifter is alway flashing. I can be going down the highway and hit the overdrive button and nothing happens, it does not shift down out of overdrive. The tranny also shift hard from 1st to 2nd. When it is in 2nd & 3rd it shutters a little until it is warmed up. Once the truck is warmed up it shifts fine. About 65% of the time when I put the vehicle in reverse the truck dies. Any help on this would be greatly appreciated.
gregw338 is offline  
post #2 of 6 Old 08-18-2011, 07:41 PM
Member
 
FIREBALL_BRIAN's Avatar
 
Join Date: Jul 2011
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
take it to your local transmission shop and have them hook up a scanner. Your trans is going to into what do the call it um I think "fail safe mode" My old 94 did that and then i had to go and they said you have this code and that code. I had a shift kit and billet torque converter so when my shifted if chirped my 38" tires. Let hope its somthing minor like the shift solinoid pack

I want to buy your firearms..... PM me
FIREBALL_BRIAN is offline  
post #3 of 6 Old 08-23-2011, 11:59 PM
Member
 
Wyogunman's Avatar
 
Join Date: Mar 2011
Location: Rawlins, WY
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Let me know what you find out because mine will die in reverse also! Mostly when I have a heavy load. I put on the extreme tune and it takes care of it but I know something is going on.

Cold air intake
Straight pipe 4"
TW Chip
Great mountain truck!

C:\Users\Amber\Pictures\2011-09-13\763.JPG
My pic is of my 1970 C-20...I know its a ford site but I love the old girl
Wyogunman is offline  
post #4 of 6 Old 09-04-2011, 03:07 PM
Compression Ignition Addict
 
troykimber's Avatar
 
Join Date: Jun 2010
Posts: 204
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
sounds like the tcc solenoid. u have to replace the the bank of solenoids. about $300 and the time.

95 sc lb 4x4 5 speed
ts 6 position chip, boost relief valve, 4" intake, 3" downpipe-5" rest of the way to a stack, fpr shim, twin 16" s-blade electric fans, poly bushings, zoom variable torque ceramic clutch with solid flywheel, hydroboost, stancor relay, exhaust brake, ss hpx line, 140v idm, bar and plate intercooler, glowshift gauges, gt grant signature series wheel with black billet hub, rockford door speakers- pioneer head unit- 2x 12" kenwood w3 subs
troykimber is offline  
post #5 of 6 Old 09-13-2011, 10:27 PM
Compression Ignition Addict
 
Join Date: Dec 2006
Posts: 1,256
Thanks: 0
Thanked 7 Times in 7 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The od light flashing is " something is wrong, get me fixed". While it is flashing, the od cancel does not work. The killing in reverse is a bad pump. The solenoid pack is rarely,, alllmost never a problem.
ipz2222 is offline  
post #6 of 6 Old 09-14-2011, 05:54 PM
Compression Ignition Addict
 
troykimber's Avatar
 
Join Date: Jun 2010
Posts: 204
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
my 96 e4od was doing the same thing and it was the solenoid.
possible front pump. kinda hard to diagnose a truck without looking it over in person.....

95 sc lb 4x4 5 speed
ts 6 position chip, boost relief valve, 4" intake, 3" downpipe-5" rest of the way to a stack, fpr shim, twin 16" s-blade electric fans, poly bushings, zoom variable torque ceramic clutch with solid flywheel, hydroboost, stancor relay, exhaust brake, ss hpx line, 140v idm, bar and plate intercooler, glowshift gauges, gt grant signature series wheel with black billet hub, rockford door speakers- pioneer head unit- 2x 12" kenwood w3 subs
troykimber is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome