ntermittent power loss - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-30-2014, 10:56 AM
Powerstroke.org Rookie
 

Join Date: Mar 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ntermittent power loss

My 97 F250 will run fine for a few miles then loose power, misses and won't rev over 2000 in neutral, then after a few minutes, it runs fine again. I have no engine codes, the fuel filter and air filter have less than 3000 miles on them, the ipc connector is clean and dry. Maybe fuel pump issue? Anyone have this problem?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-30-2014, 04:36 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Glen Allen Va
Posts: 496
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Try an oem Cam position sensor /CPS ,they're notorious for what you described .A real pita when it's acting up isn't ?
Reply With Quote Quick reply to this message
  #3  
Old 03-31-2014, 03:11 PM
Powerstroke.org Rookie
 

Join Date: Mar 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well that wasn't it. Replaced it and truck acts the same. Maybe low pressure stage of the fuel pump?
Reply With Quote Quick reply to this message
  #4  
Old 04-01-2014, 03:37 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Glen Allen Va
Posts: 496
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
I have had pump failures on both PSD that I have owned and both were leaking at the weep hole but I never had a pressure problem .
Sorry about the CPS advice but keep the other for the future .
Reply With Quote Quick reply to this message
  #5  
Old 04-01-2014, 01:36 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Houston, Tx
Posts: 484
Thanks: 1
Thanked 7 Times in 7 Posts
Feedback Score: 0 reviews
Could be fuel pump or fuel filter/FPR screen issue. Possibly IPR issue, do you have a place that can scan it and check all the sensors?

Also when it stumbles and won't rev try turning it off and checking the level of the fuel bowl and HPOP and see where it's at. Just throwing some stuff out there.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:15 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors