Two Questions - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-28-2014, 08:06 AM
Powerstroke.org Rookie
 

Join Date: Nov 2010
Location: Western Kansas
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Two Questions

I have a 1997 F250 7.3 with 131K.
First question: I have noticed that when I first start the motor when it is cold it takes about 10 seconds to fire up even when it is plugged in. I seems like it is losing fuel pressure to me but I am not 100% sure on that. I have been told tat it may be the HPOP but I don't want to spend the money if that is not the problem. I have replaced all the glow plugs and relay as well as the valve cover gaskets and electrical connectors.
Second question:
My water pump is about to go out and I am looking for the best replacement. I was looking at the Navistar pump with the built in coolant filter but I was tld that wouldn't work on my truck. Seems odd considering all the pumps from 1996-2003 are all supposed to be the same. I am also looking at using the 203 degee thermostat when I replace the water pump and want to make sure that is a good choice. Also want to add a remote coolant filter set up since the navistar pump will not work.

Last edited by tkuffler; 03-28-2014 at 08:09 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:15 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors