rough idle slow acceleration HELP PLEASE - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-17-2014, 05:29 PM
Premium Member
 

Join Date: Mar 2014
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
rough idle slow acceleration HELP PLEASE

ok i have a 97 f350 7.3l. it sat for 7 years. finally got the nerve to pull it out and get it running. i did a buzz test on the injectors and it was good. i replaced the valve cover gasket due to a burnt wire and no change. i cleaned out the back pressure sensor tube and no change. what do i need to do next. the truck has a hard time to start the first time and then it fires right up after that. it idles rough and when i hammer on it. it just drags and slowly raises. but when it warms up. it kinda idles a little better. but still vibrates. what do i need to do. thanks for any help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-17-2014, 07:14 PM
Compression Ignition Addict
 

Join Date: Nov 2012
Posts: 454
Thanks: 6
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Do you have access to codes? How is the fuel system? Any rust? Did you change cps? Also need to check icp and ipr..
Reply With Quote Quick reply to this message
  #3  
Old 03-17-2014, 07:37 PM
Premium Member
 

Join Date: Mar 2014
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yeah. it would throw an 0470, backpressure sensor circuit error. thats it. we cleand the tube out and checked the sensor. and the code went off but no change. we drained the fuel and cleaned the tanks. and only rust is on the frame. i did not change the cps and did not check icp or ipr. heck i dont even know what that is or where its located in the engine bay. first time to dig into a 7.3. or a diesel let a lone. and i have a very small oil leak in the hpop gasket. could that be a problem.
Reply With Quote Quick reply to this message
  #4  
Old 03-17-2014, 07:53 PM
Premium Member
 

Join Date: Mar 2014
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i feel like im in way over my head.and most likely am, but this truck has a lot of mental value and due to my funds i cant just drop it off to get fixed. thank you for any help and teaching me what to do.
Reply With Quote Quick reply to this message
  #5  
Old 03-17-2014, 08:09 PM
Premium Member
 

Join Date: Mar 2014
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok i looked up the icp ipr and cps. im going to replace them tomorrow evening and let you know what happens. thank you.
Reply With Quote Quick reply to this message
  #6  
Old 03-18-2014, 07:09 AM
Compression Ignition Addict
 

Join Date: Nov 2012
Posts: 454
Thanks: 6
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
No problem that's what the forum is for. I'm leaning toward ipr but there are several things that could cause this. You should check and clean every ground you can find while your in there too.
Reply With Quote Quick reply to this message
  #7  
Old 03-18-2014, 05:28 PM
Premium Member
 

Join Date: Mar 2014
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How do u put videos on this thing. I checked all 3 sensors. No change so I made a few videos.
Reply With Quote Quick reply to this message
  #8  
Old 03-18-2014, 06:08 PM
Premium Member
 

Join Date: Mar 2014
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i sent them to ur email. from my wifes email
Reply With Quote Quick reply to this message
  #9  
Old 03-19-2014, 08:20 AM
Compression Ignition Addict
 

Join Date: Nov 2012
Posts: 454
Thanks: 6
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Sounds like a bad injector to me. Post this in obs chat so we can get more opinions. I'd do a cylinder contribution test.
Reply With Quote Quick reply to this message
  #10  
Old 03-19-2014, 05:22 PM
Premium Member
 

Join Date: Mar 2014
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
obs chat? dude i have no idea what that is or how to get to it. i still cant figure out how to get the videos on this forum
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:25 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors