help please! pcm vss cps?? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-03-2014, 05:56 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
help please! pcm vss cps??

hey guys im new here, ive got a 1995, f350 2wd its obdII, its got codes, p0500-vss malfunction, p0603-internal control module KAM malfunction, P0344-CPS circuit intermittent, P0237-Turbo boost sensor A circuit low, and P0470.

The truck started dying while driving or while warming up, now it is having shifting issues, IE hard, late, stalling, and jerking. The speedo isnt working, and the miles arent showing anything, just lighting up. also the od off light is blinking. if anyone could point me in a direction, ive been hearing PCM from some ppl i have spoken to, thanks in advance!

Dave
daves95stroker is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-04-2014, 08:50 AM
Compression Ignition Addict
 
Join Date: Apr 2008
Location: Wellington Nevada
Posts: 8,701
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 38 Times in 38 Posts
Feedback Score: 5 reviews
First try a CPS.
CT Performance, Inc. is offline  
post #3 of 4 Old 03-04-2014, 08:56 AM
Compression Ignition Addict
 
Join Date: Aug 2008
Location: Madison, WI
Posts: 3,696
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 4
Thanked 114 Times in 110 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by daves95stroker View Post
and the miles arent showing anything, just lighting up.
Not sure what that means. "Lighting up" could mean the illumination light, or the number itself. Does a _number_ appear in the odometer? If it shows a number, but fails to count up, the PSOM is _probably_ good, and the fault lies with the VSS and/or the wiring from the VSS to the PSOM. Have you removed and inspected or tested the VSS?

CPS is a separate problem; if there's an aftermarket CPS in there, get it out and replace with Ford or International part ONLY.
madpogue is offline  
post #4 of 4 Old 03-04-2014, 10:33 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
There are no numbers, just the background light, n I'll try the ford cps, used advance auto brand n it didn't help, got a vss yesterday, just gotta put it in
daves95stroker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome