Possible turbo problem - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-07-2014, 09:36 PM Thread Starter
Powerstroke.org Rookie
Join Date: Feb 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Possible turbo problem

I have a 96 F-350. Starting last week, when I start off, just before the shift, I get a wicked loud air hiss, my turbo drops out and I get about 50% loss of power. If I punch the pedal, the air hiss goes and my turbo comes back. Problem is, before the next shift it happens again. And every shift after that. Strangest thing is, it doesnt happen every time I drive the truck. About half the time, it starts and runs normal. Crawled over the motor looking for an exhaust leak but nothing. I read the sticky but I'm still hoping to get some idea how to fix it. It never happened in the 4 years I've owned it and temperature doesnt seem to matter. Happened at 5 degrees the other day and at 50 degrees today. Stock motor with AFE air kit.

Last edited by Mainer; 02-07-2014 at 09:41 PM.
Mainer is offline  
Sponsored Links
post #2 of 2 Old 02-08-2014, 07:22 AM
Compression Ignition Addict
Join Date: Dec 2011
Location: Northern Arizona
Posts: 2,146
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 4 reviews
Sounds like the exhaust back pressure valve is closing. Don't know what to tell you about why it is working now and when it wants to other than the solenoid that allows the oil to close the valve is malfunctioning and has a mind of it's own. Most of us at minimum unplug the electrical connector that is just below the inlet side of the turbo. A lot of us do a complete delete of the ebpv because it gets rid of a huge potential oil leak and gets rid of a exhaust restriction.

97 F250 Xlt, built E4od, D60 swap, Baby swamps, tunes by Dp
1.0 turbo housing, 203* t-stat, diy 6637, 4" exhaust
Diy intercooled, 6.0 fan, Diy 140v Idm, Isspro Ev gauges
On board air,E-fuel, 5" lift on 35's
320000 miles
1Dieselman is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome