help needed for engine missing - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-10-2013, 02:43 PM Thread Starter
Compression Ignition Addict
Join Date: Mar 2009
Posts: 468
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
help needed for engine missing

About 2 weeks ago I cleaned the ebp tube and sensor. the tube was clogged solid. now I've been feeling it seem to miss slightly. slightly rough at idle and while cruising. in park and revving to motor it shakes bad like a bad miss. I pulled these codes help needed for engine missing-imageuploadedbyag-free1381441291.822509.jpghelp needed for engine missing-imageuploadedbyag-free1381441301.239269.jpg
also watching the psi reading from the sensor at idle was about 15psi and while revving the motor about 18/19psi. the exhaust valve fault is from my ebpv being unglugged. the truck runs fine otherwise, no loss of power, and no smoke.

could it be a bad ebp sensor?

Sent from Free App

Last edited by tony0713; 10-11-2013 at 04:11 AM.
tony0713 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome