1997 7.3 all stock.. runs crappy after warm - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-01-2013, 08:07 PM
Powerstroke.org Rookie
 

Join Date: Oct 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question 1997 7.3 all stock.. runs crappy after warm

ok guys this is blowing my freakin mind!! i just purchased a 1997 7.3 from a shop that obtained posession thro machanics lean.. i got it towed home i immmediatly found hpop was not pumping any oil, i did this by cranking several minutes with icp out of the driver head, oil never made it into the head, i replaced the hpop with one out of a 1999 core motor witch ran wen pulled, oil imediatly filled the heads she fires up! i drive her around the block, she feel sluggish i drop both tanks clean them out including the sump screens, blow out all the lines with air, clean fuel bowl, regulator, and replaced cam driven lift pump just to be sure, she ran 50 psi at the regulator shrader valve.. i go for drive she has tons of power she is alive!! after she warms up (ya i was to excited to wait i drove her cold) she cuts out, i got the peddle to the floor and no power i let off the pedal all the way she iddles rough but does berily idle, i throttle out of gear.. she dies down i let go she idles again roughly.. idles for bout a min and she is fine runs with all power for 2 miles and repeat!! i have replaced cps, ebp and icp.. strait from ford did not effect the symptoms it throws cps code and ebp codes still.. pulled all injectors all o-rings checked oil there r no high pressure oil leaks in any of the injectors.. could the ipr do this? wat r some test for the ipr? i start her up early morning and just drive i can do 30 miles b4 she acts up but soon as she is warm then problem!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-02-2013, 10:27 AM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 1,626
Thanks: 0
Thanked 24 Times in 24 Posts
Feedback Score: 0 reviews
You might want to replace (or check) the IPR o-rings. Cheers!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:47 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors