Glow plugs gone - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-29-2013, 02:42 PM
Compression Ignition Addict
 

Join Date: May 2011
Posts: 191
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Glow plugs gone

So I just replaced the glow plugs in my truck about a month ago along with the relay and valve over gaskets and wiring harness's. Started awesome and now it's back to the same no start. I didn't use ford plugs or relay. Then I was told you should so I put a ford relay in and it still doesn't work. None of the harness's are melted everything seems fine. Is it possible that the plugs went that fast ? The brand of plug I used were autolites.

I'm thinking I'll just go get some ford plugs and replace them again.


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-29-2013, 07:20 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 1,800
Thanks: 0
Thanked 40 Times in 40 Posts
Feedback Score: 0 reviews
Measure the voltage drop across the relay's large terminals when the plugs are active. You should get no more than a 0.3V drop. I would get rid of the Autolites as soon as you can otherwise you most likely will have issues removing them later. Cheers!
Reply With Quote Quick reply to this message
  #3  
Old 09-29-2013, 08:50 PM
Compression Ignition Addict
 

Join Date: May 2011
Posts: 191
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Patrick Feeley View Post
Measure the voltage drop across the relay's large terminals when the plugs are active. You should get no more than a 0.3V drop. I would get rid of the Autolites as soon as you can otherwise you most likely will have issues removing them later. Cheers!
Okayy will do. And why will I have issues removing them later ?


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #4  
Old 09-30-2013, 11:38 AM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 1,800
Thanks: 0
Thanked 40 Times in 40 Posts
Feedback Score: 0 reviews
It is well known (at least in PSD circles) that the Autolites like to swell and break off when trying to remove them. Cheers!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:53 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors