97 7.3L trips checklight, dies then starts ?? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-14-2013, 07:44 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Location: Grants New Mexico
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
97 7.3L trips checklight, dies then starts ??

Hi, hoping someone here may have ran into this. My 97 will start on occasion and show an engine check light. It will be idling fine then when the light goes off the engine will stumble or more recently completely die. It will then start right up with no check light and run fine. I have replicated this at least 3 or 4 times. I changed the fuel filter, added some Howel's, and changed the cam position sensor to no avail. I have a superchips tuner and run it on performance and also have 4 inch exhaust. Popping 3 codes - p0344, p0221 and p1280. I didn't clear codes after the cam sensor.
Any input would be appreciated,
Thanks,
Chris
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-16-2013, 06:53 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Location: Grants New Mexico
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Anyone ?
Reply With Quote Quick reply to this message
  #3  
Old 09-16-2013, 08:42 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 1,797
Thanks: 0
Thanked 40 Times in 40 Posts
Feedback Score: 0 reviews
P0221 is for the idle validation switch (two wire switch on the accelerator pedal), so maybe check the wiring and switch operation (switch is open at idle and closes when pedal is pressed just off idle position). The P1280 is ICP out of range low, so check the wiring and connector to the ICP sensor (any oil in the connection?). Cheers!
Reply With Quote Quick reply to this message
  #4  
Old 09-16-2013, 09:51 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Madison, WI
Posts: 3,108
Thanks: 3
Thanked 74 Times in 72 Posts
Feedback Score: 0 reviews
What does it do when you set the tuner back to stock and remove it?
Reply With Quote Quick reply to this message
  #5  
Old 09-18-2013, 12:24 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Location: Grants New Mexico
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I pulled tune off and cleared codes day before yesterday. Same issue and now popping a code 603 ???
Thanks,
Chris
Reply With Quote Quick reply to this message
  #6  
Old 09-18-2013, 01:56 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 1,797
Thanks: 0
Thanked 40 Times in 40 Posts
Feedback Score: 0 reviews
P0603 is normal for truck running a chip or tuner (just means power was lost to the PCM, Keep Alive Memory or KAM). Cheers!
Reply With Quote Quick reply to this message
  #7  
Old 09-18-2013, 05:04 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Location: Grants New Mexico
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Patrick Feeley View Post
P0603 is normal for truck running a chip or tuner (just means power was lost to the PCM, Keep Alive Memory or KAM). Cheers!
Thanks, I pulled the plug to the icp and there was oil in it. Shall I surmise that this means it is faulty ?
Thanks in advance
Reply With Quote Quick reply to this message
  #8  
Old 09-18-2013, 06:58 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 1,797
Thanks: 0
Thanked 40 Times in 40 Posts
Feedback Score: 0 reviews
Yes, it may run with it, but it is leaking internally. Cheers!
Reply With Quote Quick reply to this message
  #9  
Old 09-19-2013, 05:16 AM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Location: Grants New Mexico
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks Patrick,
I will pick one up today . Their expensive little buggers though.
Chris
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:30 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors