help, no start no oil pressure - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-12-2013, 07:53 PM Thread Starter
Compression Ignition Addict
 
timmy's Avatar
 
Join Date: Mar 2006
Location: Silver Creek,NY
Posts: 220
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
help, no start no oil pressure

My 96 up and died on me on my way to work , narrowed issue down to lpop. Changed out pump and now I still have no oil pressure. The truck will start and run temporarily when hpop reservoir is filled. We pulled oil filter and cranked motor over, no oil at filter housing. Any help would be greatly appreciated, I'm at a loss for ideas.

96' f-350 2wd,5spd, C+C w utility body, 370,000miles
timmy is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-13-2013, 01:27 PM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,229
Thanks: 0
Thanked 89 Times in 87 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
Cracked oil pickup tube? There's a procedure for overfilling the crankcase and jacking up the rear end of the truck to check. I'll look and see if I can find it. Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
post #3 of 4 Old 09-13-2013, 06:20 PM Thread Starter
Compression Ignition Addict
 
timmy's Avatar
 
Join Date: Mar 2006
Location: Silver Creek,NY
Posts: 220
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The pickup tube is all I can come up with, pulling the motor tomorrow to find out.

96' f-350 2wd,5spd, C+C w utility body, 370,000miles
timmy is offline  
post #4 of 4 Old 09-13-2013, 07:51 PM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,229
Thanks: 0
Thanked 89 Times in 87 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
Isn't there an o-ring for the pickup tube to front cover joint? You might check to see if it is missing or damaged. Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome