Surge on acceleration - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes
  • 1 Post By clatterindiesel
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-21-2013, 06:19 AM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Inglis, Florida
Posts: 709
Thanks: 6
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Surge on acceleration

Hate to be asking and not figuring it put myself, especially since i have a hunch or 2. But I have been busy and no signs of slowing down soon

Truck is a 97 F250 ECLB 4x4 E4OD with 322 on clock. Before it is up to perating temperature the truck surges on acceleration. Idles fine cruises fine. But surges on acceleration. Does so at light throttle, medium throttle, or heavy throttle. Youcan feel the truck itself surging and hear motor. So it isnt a busted tach. At operating temp it is smooth as butter. No loss of power. I have had a leaky fuel pump for a bit and thinkjng that it is getting slap wore out and I need to change it. I have every part to do so in garage but the time to do it. What are your thoughts on this theory. Also considering throwing a CPS at it for heck of it.

If anyone has any experience with this exact issue I would love to hear about it.


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-26-2013, 05:48 PM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Inglis, Florida
Posts: 709
Thanks: 6
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well....CPS fixed it. In case anyone wanted to know.


Sent from AutoGuide.com Free App
garyeco likes this.
Reply With Quote Quick reply to this message
  #3  
Old 06-20-2014, 07:14 AM
Member
 

Join Date: Dec 2010
Location: nw corner of wash. state
Posts: 81
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've encountered same problem plus sometimes when I'm sitting at a light,idol rpm will vary a little. Oh yeah, 94 CC F-350,310K. It's getting to the point of being annoying. Thinking it was maybe a fuel filter/pressure issue. Will try CPS sensor first.Thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:01 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors