will not rev/misfires - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-26-2013, 02:18 PM Thread Starter
Powerstroke.org Rookie
Join Date: May 2013
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
will not rev/misfires


Hi guys, my 97 PS is running like arse.. Hopefully you can help. It starts and idles fine, however under load or revving it, it breaks up as you can hear in the video. I have done the following.

1. inspected the fuel filter (which was replaced 300 miles ago) and it was prisitine

2. cleaned out the fuel pressure regulator screen (it was nasty but had no effect)

3. checked fuel pressure (72 psig at idle)

4. unplugged the injector pressure control sensor (still acted the same)

5. no codes.

6. It seemed to occur right when I hooked my cheapo actron scanner to it, which I have since learned doesn't work anyhow.. I was looking for another problem which I have solved.. I dunnno if this is involved or not but it seemd to happen at that time.

7. mm that's about it.. Thanks for any info!

jeepenstein is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome