'96 oil leak help - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-02-2013, 04:56 PM Thread Starter
Powerstroke.org Rookie
Join Date: Jun 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
'96 oil leak help

Hey guys, I just bought my first diesel ever it's a 1996 xlt. Well yesterday I out driving around and got in the throttle and noticed the check engine light came on. I pulled into a parking lot turned the truck off and back on the the light went off. So when i got home i crawled up under it just kinda on a wim and I saw oil dripping of the tranny oil pan. I looked all around and noticed it was coming off the top of the tranny so I figured it was coming out of the motor somewhere. So I popped the hood and right behind the turbo on the firewall was oil spray and I also noticed some dripping of the passenger side exhaust manifold. Today I cleaned the motor cranked it and let it idle for awhile and held it at about 2k rpm for a few seconds and nothing, no oil. I took it on about a 5 min drive and no oil. Then I went on about a 2 or so mile drive and sure enough it was leaking. So I'm thinking (hoping) the o-rings on the pedestal are bad and letting oil through. The truck has 157k on the clock and has been sitting for awhile. Let me know what y'all think, thanks.
P.s. i've done a lot of searching on other forums and this one is by far the best. All you guys seem like cool dudes and are very helpful
Blowen_coal is offline  
Sponsored Links
post #2 of 2 Old 06-02-2013, 07:00 PM
Unpremium Member
gaspipe's Avatar
Join Date: Dec 2011
Location: Hootersville, TN
Posts: 700
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Or the seal on the piston on the exhaust back pressure valve failed. O-rings most likely. Fairly common stuff, but a bit of a headache to fix. Not hard, just patience.

'95 F250 4x4 ECLB 295k - ZF5, Southbend, 4.10, van pedestal, EBPV & CCV delete, 1.0 ex housing, 3" DP, 4" exhaust, BFAF, 140v IDM, MagHytec diff cover, HD front springs, 16x8 alloys
'95 F-Superduty 4x2 CM 12' Flatbed 33k - E4OD, 5.13, Banks intercooler, van pedestal, EBPV & CCV delete, 1.0 ex housing, 3" DP, 4" exhaust, BFAF, PHP tunes, 6.0 fan, 140v IDM, TruCool, MagHytec diff/pan, Dieselsite external trans filter, Autometer gauges, 180w LED light bar
gaspipe is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome