massive oil leak. DS front on valve cover - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-20-2013, 04:54 PM Thread Starter
Compression Ignition Addict
 
AddictedOffroad's Avatar
 
Join Date: Jan 2012
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
massive oil leak. DS front on valve cover

1994.5 PSD.

Oil is running out at a steady stream from under the ICP plug. Driver side front portion. Its on the valley side, but under the valve cover. Basically there is a gold plate that has a recessed allen head bolt in it below the ICP. Its running out there. A lot of oil in a steady stream. I limped it home, but its not drivable at this point until its handled.

Its not coming from the HPOP, but right below where those lines run.

CCV maybe plugged? Or, something else maybe? No CEL on. No other issues. Just started today after around 200mi of driving around.

Scotty
1999.5 F350 DRW, CC, LB, A/T, 7.3L. Bank Exhaust brake, 4" Exhaust, BD power Thruster II turbo, PHP Hydra
AddictedOffroad is offline  
post #2 of 3 Old 05-20-2013, 06:23 PM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,210
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 79 Times in 77 Posts
Feedback Score: 0 reviews
I know the plug you are speaking of, although I've never removed it or seen it leak. It may be another HP oil rail plug. It probably needs another o-ring, and if so use Viton. Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
post #3 of 3 Old 05-20-2013, 06:58 PM Thread Starter
Compression Ignition Addict
 
AddictedOffroad's Avatar
 
Join Date: Jan 2012
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Patrick Feeley View Post
I know the plug you are speaking of, although I've never removed it or seen it leak. It may be another HP oil rail plug. It probably needs another o-ring, and if so use Viton. Cheers!
Well, I found it. It was the lower hex portion that the ICP screws into. It was leaking where it threads into the high pressure rail on the head. It must have backed off a little. FWIW, I lost almost a full gallon of oil out of the motor.

Scotty
1999.5 F350 DRW, CC, LB, A/T, 7.3L. Bank Exhaust brake, 4" Exhaust, BD power Thruster II turbo, PHP Hydra
AddictedOffroad is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome