cps has went bad bad??? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 05-19-2013, 06:10 AM Thread Starter
Member
 
ole96stroker's Avatar
 
Join Date: Jun 2012
Location: damascus va
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
cps has went bad bad???

So i was coming down the interstate last night and my truck just shut off and wouldnt start back, im getting fuel and the rpm's will go up when you crank it. It has been acting funny here lately about idling and no check engine.light, is this mpre then likely my cps ???thanks

******1996 ford f250 powerstroke 5 spd 4x4******
***170,000 miles, ts 6 pos, intake, exhuast***
ole96stroker is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-19-2013, 09:28 AM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,227
Thanks: 0
Thanked 87 Times in 85 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
You might change it just to see (they are cheap enough these days to do that). If it doesn't work you have a spare for the glovebox (always a good idea). Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
post #3 of 7 Old 05-19-2013, 01:03 PM Thread Starter
Member
 
ole96stroker's Avatar
 
Join Date: Jun 2012
Location: damascus va
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
well stil no start just put one on. any ideas what else could be it??? thanks

******1996 ford f250 powerstroke 5 spd 4x4******
***170,000 miles, ts 6 pos, intake, exhuast***
ole96stroker is offline  
post #4 of 7 Old 05-19-2013, 01:43 PM Thread Starter
Member
 
ole96stroker's Avatar
 
Join Date: Jun 2012
Location: damascus va
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Could it be my icp? is say's if covered in oil inside it will go bad and mine is where the pigtail goes in.thanks

******1996 ford f250 powerstroke 5 spd 4x4******
***170,000 miles, ts 6 pos, intake, exhuast***
ole96stroker is offline  
post #5 of 7 Old 05-19-2013, 07:07 PM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,227
Thanks: 0
Thanked 87 Times in 85 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
It could be the ICP (but hate to keep throwing parts at it). Will it start with the ICP unplugged? How's the wiring to the IPR look? Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
post #6 of 7 Old 05-19-2013, 08:06 PM Thread Starter
Member
 
ole96stroker's Avatar
 
Join Date: Jun 2012
Location: damascus va
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I believe I found out what it is, I took my fuel bowl apart to where I could see the ipr and the nut has some how came off the end of it the one that goes against the bushing, the part that you plug the pigtail to was just moving freely, gonna go get a nut and hope this fix's her.

******1996 ford f250 powerstroke 5 spd 4x4******
***170,000 miles, ts 6 pos, intake, exhuast***
ole96stroker is offline  
post #7 of 7 Old 05-20-2013, 12:57 PM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,227
Thanks: 0
Thanked 87 Times in 85 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
It should fix it. If the solenoid is moving around the IPR may or may not work correctly. Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome