97 PSD Symptoms miss/lope low powers around 2000 rpm seems to cut out - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-25-2013, 01:24 PM
Powerstroke.org Rookie
 

Join Date: Apr 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
97 PSD Symptoms miss/lope low powers around 2000 rpm seems to cut out

So my truck has what I would call a miss?



At start up white smoke not on all cylinders.

Noticeable miss/lope



Once warm the smoke really lightens

but the miss/lope is still there



does not have power like it should.



no codes (have a gauge)

tested the fuel pressure is 60+/- at idle

tested the HPOP 750 psi at a warm start up

new ICP

new CPS

rebuilt fuel bowl

new GPR

good batteries and cables



Done a buzz test and passed





I was planning on testing the compression and then I am most leaning towards injector orings???



Thoughts? Anyone with other suggestions?



pulled my fuel filter which was new and has maybe 25 miles on it here is what it looks like. If this indicative of faulty injector orings? I remember it being much more orange when I installed it several weeks ago.

What do you guys think?
Attached Thumbnails
97 PSD Symptoms miss/lope low powers around 2000 rpm seems to cut out-fuelfilter_zpsb0428f13.jpg  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-26-2013, 08:18 AM
Powerstroke.org Rookie
 

Join Date: Apr 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
come awn guys I am looking for some expertise here....
Reply With Quote Quick reply to this message
  #3  
Old 04-26-2013, 08:31 AM
Premium Member


 

Join Date: May 2010
Location: a base near you
Posts: 1,101
Thanks: 11
Thanked 20 Times in 18 Posts
Feedback Score: 1 reviews
I'd recommend a set of injectors,
Reply With Quote Quick reply to this message
  #4  
Old 04-29-2013, 01:13 PM
Powerstroke.org Rookie
 

Join Date: Apr 2013
Location: Gig Harbor, WA
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I hope someone chimes in here. I'm suspecting my o-rings, although it does not have the symptoms you do. My filter looks pretty much like yours though. I rubbed my finger along the side of the fuel and did not notice any black on it. Diesel looked ok, greenish tint, but IDK what it should look like. Did you notice if the diesel in the fuel bowl looked different?
Reply With Quote Quick reply to this message
  #5  
Old 04-29-2013, 01:23 PM
Powerstroke.org Rookie
 

Join Date: Apr 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Drochette View Post
I hope someone chimes in here. I'm suspecting my o-rings, although it does not have the symptoms you do. My filter looks pretty much like yours though. I rubbed my finger along the side of the fuel and did not notice any black on it. Diesel looked ok, greenish tint, but IDK what it should look like. Did you notice if the diesel in the fuel bowl looked different?
The fuel in bowl did have a greyish tint as did my fuel filter. When I changed it several months ago I remember it being much clearer looking.
Reply With Quote Quick reply to this message
  #6  
Old 04-30-2013, 09:02 PM
Compression Ignition Addict
 

Join Date: Sep 2012
Posts: 154
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
my 95 spd was having a hard start if sat long and would smoke thick white till warmed up once started. if was already warm not much issue starting and only a little white smoke. wasn't changing fuel colour or using oil. changed injector O-rings and hard start and smoke went away. I suspect problem was fuel was draining down into cylinder when parked for long time. sounds like your having same problem.... ohh and forgot to mention at 2200-3000 rpm when romping on it, it would "starve for fuel" or cut out.

I got my orings for $126. for all.. they go for $6 - $15 average.. for wants like $25 each.
Reply With Quote Quick reply to this message
  #7  
Old 05-03-2013, 02:12 PM
Powerstroke.org Rookie
 

Join Date: Apr 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So I think that I will be pulling the valve covers, do a compression test, assuming it comes back good pull the Injectors and replace them with some Stage 1 or 2 Rosewood or Sniper injectors and put new glow plugs and UVC Harnesses all at the same time.

Right after I will be doing my ZF swap and adding a Matt Robinson tuned chip. Then a E-Fuel conversion.
Reply With Quote Quick reply to this message
  #8  
Old 05-29-2013, 12:47 PM
Powerstroke.org Rookie
 

Join Date: Apr 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So I pulled the valve covers and found 7 AA injectors and 1 AB injector. When testing each of them the AB injector made no change so I pulled it out

Here is what the old AB injector looked like when removed
Attached Thumbnails
97 PSD Symptoms miss/lope low powers around 2000 rpm seems to cut out-imag0270_zps807e36b8.jpg  
Reply With Quote Quick reply to this message
  #9  
Old 05-29-2013, 12:51 PM
Powerstroke.org Rookie
 

Join Date: Apr 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ordered a new AA injector and installed it and man it runs a lot better seems way more responsive but still a slight miss/hick up at about 2200 rpms so I think the other o rings probably look similar.

ordered a set Alliant o rings, TS chip, intake and wicked wheel. At the same time will throwing in the new UVCH's and rebuilding the turbo/pedestal.

once it is running tits then will be doing the ZF47 swap with the South bend clutch in my garage.

Can wait.....
Reply With Quote Quick reply to this message
  #10  
Old 04-08-2014, 04:18 PM
Powerstroke.org Rookie
 

Join Date: Apr 2013
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just because every thread I looked at never had the solution to the problem. It was fixed and who cares about the next guy with the same problem?????


Well I ended up swapping the 1 odd ball injector and it helped, replaced all of the orings on the other injector and still not great.

One of the first thing I did was replace the cps with a cheapy aftermarket grey one from rock auto.

Bingo.....

I know that I had injector issues as well but after all of the injector issues was squared away I still had want I would best call injector knock/ some might call it kindof a timing knock. at around 2200-2600 rpms which was much worse when cold.

threw my original grey ford cps in and wala runs SO much better no miss/injector knock and I can actually turn my chip up and feel the power. FINALLY A HAPPY POWERSTROKE OWNER. only took a year of trial and error after selling my Cummins. What is next probably some stage 1 or 2 injectors and an efuel system.


__________________
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:24 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors