I suspect CPS issue... - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-18-2013, 01:18 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I suspect CPS issue...

Hey y'all. This forum had definitely helped me a ton so far. Over the past few weeks, I changed glow plugs and glow plug relay, put new o-rings on the injectors, went with a non EBPV turbo pedestal, rebuilt the turbo and had it balanced, and installed new turbo and pedestal o-rings. The glow plugs and the relays were both toast, and I played hell getting a few of them out. 301k miles and still had the original glow plugs. I got everything changed out, fresh oil and filter, new fuel filter, and I also resealed the fuel filter housing and installed new fuel lines. The old fuel pump was leaking diesel really bad so I changed it out as well and installed new banjo baskets. I primed the fuel filter housing and and waited until the wait to start light went off. It was 26 outside and she fired right off. I was impressed. So I was driving the old diesel to work on Monday and she started bucking? I could watch the tachometer and see how the RPM's would jump from around 1800RPM to about 2200RPM. Also would notice it drop from 1800RPM to 1300RPM. The "bucking" would happen very quickly. It would shake the hell out of the truck for the split second it would do it. I think I had to go home and change my pants the first time it happened! Anyways, I've researched the forums some and noticed that most people who would post threads regarding the CPS would state how their truck would idle really rough and die intermittently and have a loss of power. The idle on mine is quite smooth for a power stroke and doesn't die nor lack any power. As far as i know, the CPS on my truck has never been changed. I went ahead and ordered a new one online, but am curious if there is something else I should look at? Any advice would be appreciated. Thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:11 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors