Rat chit in the turbo intake side...what now??? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-03-2013, 04:03 PM
Member
 

Join Date: Mar 2013
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Rat chit in the turbo intake side...what now???

Hello,

So i've been isolating a problem in my new to me 95 e350 7.3 ambulance. I have it narrowed down to the turbo being full of rat chit.

Do i pull the whole turbo and try to clean it out? If so, is there a good step by step write up on that?

Or do i clean what i can out of it while its still on the engine?

Long story short...its been sitting 4 yrs...i picked it up cheap...only 91000 on the ticker.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-03-2013, 04:15 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Mercer County WV
Posts: 2,988
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would remove it. You can get a better cleaning job and clean more of the engine valley and check the wiring, etc etc.

This thread may help...
Turbo Charger Removal
Reply With Quote Quick reply to this message
  #3  
Old 04-03-2013, 05:46 PM
Member
 

Join Date: Mar 2013
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
good idea...and fix that fuel leak i just found after i got the turbo out. Wasn't as bad as i thought. I have still yet to figure out how a rat got in there...and must of been a big one judging by the size of the turds. Beats anything i ever seen.

Gonna run it by my local superduty shop in the morning and see about a rebuild or atleast good cleaning.

Thanks,

Jarrett
Reply With Quote Quick reply to this message
  #4  
Old 04-05-2013, 06:34 PM
Member
 

Join Date: Mar 2013
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Got the turbo all cleaned up and reinstalled. Also got the fuel leak fixed. Was the fuel filter sensor. I just capped it and so far it's working. Ambulance runs great now except for a slight wobble in the front right and pulling to the right. Prob just needs 2 new front tires after sitting so long.

Thanks,

Jarrett
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:59 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors