helping a friend - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-25-2013, 04:53 PM Thread Starter
Join Date: Jul 2010
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
helping a friend

Working on a friends 94 7.3, need some help. It died with no restart. I checked fuse #22 and it was blown. I unplugged the fuel bowl heater and replaced the fuse. When cranking it does show rpm so its not the cam sensor. No wait to start light. No aftermarket chip. After replacing the fuse it is not blowing the new fuse. Any help would be great. I dont know much about the 7.3 I have a 6.0 and a 5.9 Thanks in advance
ClaytonG is offline  
Sponsored Links
post #2 of 2 Old 03-26-2013, 07:28 AM
Compression Ignition Addict
superduty4x4's Avatar
Join Date: Nov 2007
Posts: 2,355
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
No WTS light means the PCM isn't getting powered up. Check the in-cab fuses and if they are ok, swap the PCM relay with one of the others and see if that helps.

97 F350 CCLB 4x4 PSD
superduty4x4 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome