Changed fuel filter, truck died after apps 10 miles. Normal - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 03-02-2013, 09:18 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Changed fuel filter, truck died after apps 10 miles. Normal

Recently purchased 97 7.3, 191k. Changed fuel filter as reg maintenance. Idled for a couple mins then parked it. Drove about 10 miles a few days after the new filter and truck died. Like it ran out of fuel. After some cranking over and 5 sec idle then die cycles..(maybe 8-10 times), truck ran fine ever since. Is this normal for the truck to have air in the filter system and die like that? Was thinking of testing the fuel pressure for signs of weak pressure or failing FP.
Spent a couple hrs researching ex. threads, but never found one specifically for this problem.
Any help appreciated. Thanks
backyardman is offline  
post #2 of 5 Old 03-24-2013, 03:26 PM
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Did you refill the fuel bowl before you started it ?
charlesheck is offline  
post #3 of 5 Old 03-24-2013, 03:50 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Thanks: 0
Thanked 27 Times in 25 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Usually it woulda died right as it was idling, but if you didn't refill it, it could be that.



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
post #4 of 5 Old 03-25-2013, 05:43 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Not a problem lately

Thanks for your reply.
It had snowed / rained pretty hard that day that it died and i also remember splashing through a large puddle.It sprayed water up into the engine. I'm thinking now that it got something wet and died for a minute. Still a bit of a mystery but it's running great now. Just go back from a weekend of camping down in Moab, UT and it pulled great.
Thanks again for your response.
backyardman is offline  
post #5 of 5 Old 03-25-2013, 03:41 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Thanks: 0
Thanked 27 Times in 25 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Water coulda got into the IDM or the PCM if your windshield leaks, but that was more a SD problem.
Did you refill the bowl after filter change?



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome