Fuel filter cap backed itself off? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-19-2013, 03:09 PM Thread Starter
Powerstroke.org Fanatic
Join Date: Nov 2011
Posts: 91
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fuel filter cap backed itself off?

I got into an accident back in september, so ive been doing a lot of work before i repaint the truck so its been sitting in my garage. I start it up and let it run every week never more than two weeks. Well this last time it was running and all of a sudden there was fuel shooting everywhere, open the hood to find out the filter cap was loose. I put a new motorcraft filter in this summer and torqued it down to specs. Has anyone else had this problem? Is it the right filter?

97 f-250 PSD, 85k as of 5/23/14, ZF5, silver w/ red stripe
Dana 60, 4in MBRP exhaust, Southbend clutch w/ single mass, Actual Tymar intake
97PowerHusk is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome