bad turbo maybe? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 01-14-2013, 12:50 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2012
Location: Centralia, WA
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bad turbo maybe?

About a week or so ago i noticed my boost gauge was not reading any boost. I dont really know about turbos or even where the gauge hooks up to but i looked under the hood anyway and all i noticed was my air filter had seperated its self from the tubing. Put it back and still no boost on the gauge. Im sorry but i can not tell if the turbo is working for sure or not, i thought it was but now i hear a weird noise.
It sound like its coming through the exhaust. When i rev it up a little i hear a sound like metal spinning on metal. Not at an idle but when reved up to like 1200 and up. It also makes it when driving, but seems to go away if i floor it a little but comes back.

Does this sound like a turbo issue?
Also if it does can i keep driving the truck till i scratch up the coin to replace the turbo ( Ive heard they are spendy)

1996 F350 xlt Crew Cab
crewcabxlt is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-14-2013, 04:11 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2012
Location: Centralia, WA
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I found the tube for the boost guage and it had come loose. There is boost, up to 10lbs when i was getting on it. and it wasnt making the noise so i am thinking it only does it when it warms up maybe?

1996 F350 xlt Crew Cab
crewcabxlt is offline  
post #3 of 3 Old 01-14-2013, 06:53 PM
Compression Ignition Addict
 
Join Date: Aug 2008
Location: Madison, WI
Posts: 3,699
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 4
Thanked 116 Times in 112 Posts
Feedback Score: 0 reviews
Boost gauge is aftermarket.

The noise - is it kind of a whssssh sound? How cold is it where you are? This might just be the EBPV - exhaust back pressure valve - closing in cold weather. Lot of fellas decommission theirs.
madpogue is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome