Cutting out around 2k, (long post, sorry) - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-03-2013, 04:41 PM
Member
 

Join Date: Dec 2012
Location: Sebring, Fl
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Cutting out around 2k, (long post, sorry)

I have a 95' psd with down pipe, straight exhaust, tymar intake, and a ts chip. About a week ago my truck started acting up and had symptoms of a bad CPS (no throttle response at times and shutting off). I changed it out and it was still running a little rough. Since I didn't need my truck for the last week, I decided to look into my injectors, I knew one was either weak or bad. After digging in I found the #8 injector not working because of a broke screw for the armature plate. Today I put a new screw in it and the injector started working for the first time in who knows how long. Smoother and quieter idle for the most part, I can hear a occasional little quiet pop when listening to the exhaust, but other than that it's smooth. When I bump the rpms up to around 2000 it cuts out and rpms drop by a couple hundred and pick back up. When driving it starts doing it around 1800. If I rev it up fast it doesn't do it sometimes. With my chip on the stock setting its worse, if I put the chip on any of the other settings it doesn't do it as bad. I put another new CPS in it today because I had this issue a couple months ago after putting a CPS in and once I replaced it with a different one it quit cutting out. Kinda confusing with all the CPS changing lol. Well when I put the new one in today, it's still doing it. I also put a new ICP sensor in today but the check engine light is still on and nothing changes when I unplug it. I hooked a meter to the ICP connector and its getting power but i guess it could be bad still? I went to advance to hook up their crappy scanner and it showed no codes but the CEL was still on. I tried unhooking the batteries to get it to go off but it didn't work. I also unhooked the map sensor to see if it would clear up the motor, it seemed to idle a little smoother but it still cut out (it might of been idling the same, could of just seemed smoother) i replaced the fuel filter about a month ago. Anyway, what could be causing my cutting out issue? Maybe a bad intake boot or plenum boots? I don't know what to do, I've searched everything I could think of and tried everything that I think might cause it. I'm getting new injectors in a couple weeks, I guess if I don't have it figured out by then I'll take it to ford and have it tested. Sorry for the long post, I just want to get as much detail in as possible. Thanks in advance for any info given!!!!


Sent from my iPhone using AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:33 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors