95 7.3L No start P1212 & P1211 - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-02-2013, 07:13 AM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
95 7.3L No start P1212 & P1211

Hello, I've creeped this site for awhile and have read many threads. I own a 95 F-350 PSD. Last night as I was driving the CEL came on while on the highway but the truck felt,sounded and drove normally. This morning I went to start the truck and It would not start with a CEL light on after 20-30seconds of cranking.
The truck is chipped (edge) which alowed me to read the codes p1212 and codes p1211.

Details:
Fuel filter changed about 400km ago.
Oil changed at about 2000km ago.
Oil is full
Oil in HPOP is full
Fuel bowl is full of fuel
I tried starting the truck with the ICP disconnected and still nothing.
ICP is dirty, but not oily.
The IPR is tight but the connector seems a little loose but I heard thats normal.
Both batteries are good and the truck is cranking great.

Please help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-02-2013, 07:15 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,234
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
ipr issue probably , need to get a better scanner on the truck and see what oil pressure actually is , and also edge box may not be pulling all code either, do some more diag before buying any parts
Reply With Quote Quick reply to this message
  #3  
Old 01-02-2013, 02:17 PM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Update: I can't get a scanner onto the truck as I dont know anyone with one. I checked the fuel pressure and sits at 10psi then jumps to 40psi while cranking.
Should I try replacing the IPR?
Reply With Quote Quick reply to this message
  #4  
Old 01-02-2013, 03:13 PM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Can I use an None edge filter IPR on a Edge filter HPOP?
Reply With Quote Quick reply to this message
  #5  
Old 01-03-2013, 04:18 PM
Powerstroke.org Rookie
 

Join Date: Nov 2012
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Try to tighten the tin nut on the back of the IPR before you replace it
Reply With Quote Quick reply to this message
  #6  
Old 01-05-2013, 06:14 PM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So I got the IPR out, and its the "edge filter" kind, problem is there is none in the province I live in, and the ford stealership wants $600 for one! I have "no edge filter" IPR from a running truck but will it work?
Reply With Quote Quick reply to this message
  #7  
Old 01-05-2013, 06:37 PM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Or can I even disassemble the one and reassemble it with the edge filter on it?
Reply With Quote Quick reply to this message
  #8  
Old 01-06-2013, 08:59 AM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump - does anyone have an answer?
Reply With Quote Quick reply to this message
  #9  
Old 01-07-2013, 03:04 PM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So I got the right IPR in the truck starts fine, But the oil pressure doesn't build into the normal section til you wait a few minutes, during this time the CEL comes on and the code P1212 comes up, then goes away when the oil pressure "normalizes". The truck seems to drive fine though. but it concerns me that it is doing that. Any ideas from anyone?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:59 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors