Oil in coolant - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 12-10-2012, 05:35 AM Thread Starter
Powerstroke.org Fanatic
 
birdco85's Avatar
 
Join Date: Nov 2010
Location: Sandy Ego
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Oil in coolant

So i noticed that there is a good amount of oil in my coolant. I did the oil cooler o-rings no to long ago but i had a heck of a time with the front bolts. I'm wondering if maybe the front cooler head to block gasket got contaminated. It does have some oil around it but while i was looking i noticed that there is some oil sludge on top of the front cover where it meets the block. So i assume i have a leaking front cover. Or maybe my head gasket is leaking out of the front? Its not the hpop or the hpop gasket. Valley does get wet with oil but I've meticulously inspected the hpop to make sure it wasn't that. If the front cover is leaking could it be contaminating the coolant?

No coolant in oil and it doesn't smell like fuel. I did order injector cups so I'm going to do those just for piece of mind.

Any thoughts guys? Anything appreciated.

Sent from my DROID RAZR because I told it to...

1995
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
F350 PSD, 4x4, CCLB, Auto, 236,xxx, Tymar, 4" Diamond Eye, PHP FU2 chip, T-500, Rosewood Stage 2.5's, DIY E-fuel, Intercooler, Gauge's (Pyro, Boost, Trans), CCV Mod, Explorer OHC....way more to come.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
birdco85 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-11-2012, 01:39 AM Thread Starter
Powerstroke.org Fanatic
 
birdco85's Avatar
 
Join Date: Nov 2010
Location: Sandy Ego
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Nothing guys? Took the accessory bracket off and can tell that the oil cooler head to block isn't externally leaking. Its coming from higher. So how often do the oil cooler cores go bad?

Sent from my DROID RAZR because I told it to...

1995
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
F350 PSD, 4x4, CCLB, Auto, 236,xxx, Tymar, 4" Diamond Eye, PHP FU2 chip, T-500, Rosewood Stage 2.5's, DIY E-fuel, Intercooler, Gauge's (Pyro, Boost, Trans), CCV Mod, Explorer OHC....way more to come.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
birdco85 is offline  
post #3 of 5 Old 12-11-2012, 10:23 PM
Compression Ignition Addict
 
444 ci's Avatar
 
Join Date: May 2009
Location: lancaster ohio
Posts: 443
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i am sure had often the oil cooler goes bad. but my 7.3 had oil in the coolent and i had a brand new oil cooler put in and i havent had any more problems. i heard the seals go bad or the inside rusts out.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
444 ci is offline  
post #4 of 5 Old 12-12-2012, 03:09 AM Thread Starter
Powerstroke.org Fanatic
 
birdco85's Avatar
 
Join Date: Nov 2010
Location: Sandy Ego
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yeah thanks, i just ordered a new core and o-ring set so we'll see. Done other people have told me that the front cover won't cause it, its pretty much just the cooler.

Sent from my DROID RAZR because I told it to...

1995
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
F350 PSD, 4x4, CCLB, Auto, 236,xxx, Tymar, 4" Diamond Eye, PHP FU2 chip, T-500, Rosewood Stage 2.5's, DIY E-fuel, Intercooler, Gauge's (Pyro, Boost, Trans), CCV Mod, Explorer OHC....way more to come.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
birdco85 is offline  
post #5 of 5 Old 12-12-2012, 06:15 AM
Compression Ignition Addict
 
jermcd's Avatar
 
Join Date: Oct 2010
Location: Central, OH
Posts: 322
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
id have to guess maybe o-rings as well... post an update later

currently driving a 335i bmw, no more powerstoke
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Previous powerstrokes-
2002- F250 XL 7.3 auto, 4x4
2001- F250 Lariat 7.3 auto, 4x4
2002- F350 Lariat 7.3 Dually, auto, 4x4. 141k miles
jermcd is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome