injector change problems - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-08-2012, 04:39 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2012
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
injector change problems

hello just changed my injectors i my 1994 f250 powerstroke diesel. My first time changing injectors and i also changed the glow plugs the truck starts but it idles really rough but i know somethings not rite but im not sure what it is. Any imput would be appreciated.
oldschooldiesel is offline  
post #2 of 4 Old 10-08-2012, 04:42 PM
Compression Ignition Addict
 
cntryboy17's Avatar
 
Join Date: Aug 2009
Posts: 475
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Is everything sealed properly and nice and snug?

Sent from my SAMSUNG-SGH-I847 using AutoGuide.Com Free App

FB: Kyle Durflinger

E99 F350 CCSB 4x4, Auto, All stock for now..., straight piped

1990 f-250 7.3idi 4x4 5 speed

Quote:
Originally Posted by oldtimer550 View Post
Chevrolet = French word for non-hetero buttsecks.
Quote:
Originally Posted by 1tonpower View Post
the wait for the coverage articles in DP is like waiting for a girl to put out for the first time....
cntryboy17 is offline  
post #3 of 4 Old 10-08-2012, 04:50 PM
Compression Ignition Addict
 
FreightShaker244's Avatar
 
Join Date: Sep 2012
Posts: 154
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
It might run a lil rough first 5 to 10 miles or so than should smooth out. How long have u driven the Truck since instal. Are you sure all 8 injectors are plugged in.


Sent from my iPhone using Autoguide

1995 F-250 7.3 Powerstroke 5 Speed, 6'' Lift. DIY Intake/Napa filter, 4" exhaust.
FreightShaker244 is offline  
post #4 of 4 Old 10-08-2012, 04:51 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2012
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
as far as i can tell everything is all snugged up nice and tight. It runs but it doesn't want to idle for me i'm looking into replacing the wire harness's for the injectors and valve cover gaskets just in case its bad wires.It's also running a check engine light now.
oldschooldiesel is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome