Engine misses at high rpm - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-07-2012, 05:37 PM Thread Starter
Compression Ignition Addict
FreightShaker244's Avatar
Join Date: Sep 2012
Posts: 154
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Engine misses at high rpm

Quick questions guys, my 7.3 5 speed, when you put it in 1st and floor it from a stand still, when it starts to yellow line in high Rpm's the motor "pops" or misses. Or if your in neutral and floor the throttle the 3000rpm it pops as well. Engine acts like its starving for fuel or can't keep up. Anyone have any ideas what's causing this.

Sent from my iPhone using Autoguide

1995 F-250 7.3 Powerstroke 5 Speed, 6'' Lift. DIY Intake/Napa filter, 4" exhaust.
FreightShaker244 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome