97 PSD, need advice - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-02-2012, 02:36 PM
Powerstroke.org Rookie
 

Join Date: Sep 2012
Location: Crane, Mo
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
97 PSD, need advice

Newbie here, I have tried to research my questions but have not seen what I'm looking for so don't shoot me for asking again. I have recently bought a 97 F350 PSD 2wd dually. It is basically stock, it does have a Superchips micro tuner and a K&N filter. I don't know alot about diesels so thats why I am here! I have a couple problems I am hoping you can help me diagnose, first off the temp never gets about the O on the word Normal on the temp gauge, is that normal? The second thing is that it does a weird slow power up when you start it, it only lasts for a second or two but you can definately hear the motor speed up. It also after being driven, and being as warm as it gets, when you let off the gas the engine rpms drop to near nothing when slowing to corner or turn into a parking lot etc. And lastly it does have the rough idle, that runs fine when on the road. Sometimes when you fire it up it seems to missing on a couple cylinders, very hard vibration that will usually stop when warmed up. I have had to unplug the EBV, even though it was clear as was the tube, and I did replace the cam sensor in it yesterday. That did seem to help with the low idle somewhat but did not solve it, nor the rough idle like I had hoped. I did try unplugging the ICP ( injector sensor) on the engine yesterday after driving it and it did not change the idle at all. And finally my last question for the moment, the HPOP oil, how often should it be changed and what kind of oil do you put in it?
I have not changed the fuel filter on the truck yet, I hope to do that tomorrow, I did hit the drain valve on it just a minute ago and it did not seem to have any water in it. This could be causing some of the rough idle problems, just wanted to see what you guys thought about the other issues as well. Any input it greatly appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-02-2012, 03:07 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,043
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
That temp gauge is worthless basically. It shows "normal" at only 150*F. Operating is more near 180*F. But it should be in the "normal range really. In the little brackets.
Read up on the HEUI motor: How HEUI works and best to convert
Now tell me, when was the oil/filter last changed and with what oil?
HPOP oil is part of the normal engine oil system. Gets changed out every time you run the motor.
You could have low fuel pressure since it is a mechanical pump.
Also, look at your turbo compressor fins. What shape are they in?
Auto or manual trans?
btw
Reply With Quote Quick reply to this message
  #3  
Old 09-02-2012, 06:02 PM
Powerstroke.org Rookie
 

Join Date: Sep 2012
Location: Crane, Mo
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I am not sure on the service history of the truck. I bought it from a dealership, I believe it was a company truck for someone. I have read to run synthetic oil in them, but this has a leaky pan and I dont want all that money on the ground! What weight and brand would you reccommend? So the oil in the HPOP, does it have to be drawn out the check hole or does it have a drain? It is an automatic, E40D, and its is throwing the tranny slip code, but it shifts ok as long as I dont get into it. How would I check the turbo fins? Pull the inlet pipe or is there an inspection plateon it?
Reply With Quote Quick reply to this message
  #4  
Old 09-02-2012, 07:05 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,043
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Just a 15W40 like Rotella is good.
The oil in the HPOP reservoir gets put there by the low pressure oil pump.
Pull the intake tube to check compressor
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:02 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors