97 Powerstroke missing around 2000 RPM - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-27-2012, 09:04 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
97 Powerstroke missing around 2000 RPM

I have a powerstroke that when the RPM gets around 2000 it starts missing. At a idle it misses sometimes. I checked the wiring harness to the injectors and I did not find anything wrong. The fuel pressure bounces between 40-60 PSI. Does anyone have any idea what can cause this?
JBirdd1989 is offline  
post #2 of 5 Old 08-27-2012, 08:15 PM
Member
 
InternationalHarvester7.3's Avatar
 
Join Date: Jul 2012
Posts: 88
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have the same problem but around 3,000.. everyone says fuel filter but I replaced mine and changed all fluids and still doing it off and on, does yours do it every time you accelerate?
InternationalHarvester7.3 is offline  
post #3 of 5 Old 08-28-2012, 04:25 AM
Banned
 
Join Date: Sep 2008
Location: Fort Bragg, NC/Buff, NY/Midlothian, VA
Posts: 5,630
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Pull the FPR screen and clean it. I bet money thats part of it.
85_305 is offline  
post #4 of 5 Old 08-28-2012, 09:41 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yes mine did it every i accelerated or got around 2000 RPM. I replaced the cam sensor and that fixed the problem, but i also cleaned the FPR screen and that was caked with stuff.
JBirdd1989 is offline  
post #5 of 5 Old 08-28-2012, 09:51 AM
Banned
 
Join Date: Sep 2008
Location: Fort Bragg, NC/Buff, NY/Midlothian, VA
Posts: 5,630
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
So its all fixed?
85_305 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome