truck shut off need help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-21-2012, 07:10 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Winfield PA
Posts: 184
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
truck shut off need help

My 96 just shut off cruising down the road with no warning. The ABS light has been on for the past couple weeks on and off. I checked the codes, had a cps code and a icp code. I put a new cps and 2 different icps in and nothing, I even tried it with the icp unhooked. Then I found a burnt injector harness, it is burnt out side the valvecover in the main harness. How do you get this connector apart and are there parts available to fix it? It still wouldn't start with that plug unplugged and the gp wire pulled out of the plug, any ideas on what else might be going on?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-21-2012, 07:24 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,071
Thanks: 0
Thanked 14 Times in 14 Posts
Feedback Score: 0 reviews
If it's burnt, that's the problem. That supplies power to the injectors to fire them.
You need to check all the UVCHs and connections and replace as needed.
Reply With Quote Quick reply to this message
  #3  
Old 03-21-2012, 07:47 PM
the baconator

 

Join Date: May 2009
Location: Easton MD 21601
Posts: 11,650
Thanks: 6
Thanked 61 Times in 58 Posts
Feedback Score: 1 reviews
they sell pigtail kits for that reason, also check the valve cover gaskets and teh UVCH
Reply With Quote Quick reply to this message
  #4  
Old 03-21-2012, 09:00 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Madison, WI
Posts: 3,119
Thanks: 3
Thanked 74 Times in 72 Posts
Feedback Score: 0 reviews
Always start with the basics:
* WTS light on?
* Does the tach move?
* Any white smoke?

Did you check fuses? Whatever boined up that harness might've blown a fuse in the process.
Reply With Quote Quick reply to this message
  #5  
Old 03-22-2012, 05:31 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Winfield PA
Posts: 184
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
WTS is on, the tach comes up to maybe 200 rpm and doesn't move while cranking, no smoke. I looked over the fuses under the hood and didn't see anything, any of them in particular to double check? anybody have a part number for the pigtail kit? Can you get it anywhere other then ford?
Reply With Quote Quick reply to this message
  #6  
Old 03-22-2012, 07:07 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,071
Thanks: 0
Thanked 14 Times in 14 Posts
Feedback Score: 0 reviews
Yea a lot of ppl sell them. Riffraff might.

My Samsung SGH-I997 made me send this.
Reply With Quote Quick reply to this message
  #7  
Old 03-22-2012, 11:38 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Winfield PA
Posts: 184
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
How do you install the new pigtail, butt connectors?
Reply With Quote Quick reply to this message
  #8  
Old 03-22-2012, 12:12 PM
the baconator

 

Join Date: May 2009
Location: Easton MD 21601
Posts: 11,650
Thanks: 6
Thanked 61 Times in 58 Posts
Feedback Score: 1 reviews
international will have them too
Reply With Quote Quick reply to this message
  #9  
Old 03-24-2012, 09:46 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Winfield PA
Posts: 184
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I now have found 2 burnt harnesses, is that just a coincidence or is there something else going on?
Reply With Quote Quick reply to this message
  #10  
Old 03-24-2012, 08:31 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2012
Location: OCALA , FLORIDA
Posts: 127
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i had all 4 harnesses burn in mine due to bad glow plugs. replace the plugs , glow plugs and valve cover harnesses and all will be good. when i did that it solved all kinds of issues.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:33 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors