oil leak in front of motor - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-21-2012, 04:28 AM
Member
 

Join Date: Feb 2012
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oil leak in front of motor

On my driver side front of motor I have a huge oil leak. appears to be behind the power steering pump. any thoughts??? 97 f 250 4x4 7.3
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-23-2012, 02:06 PM
Powerstroke.org Rookie
 

Join Date: Apr 2011
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Possibly could be from the oil cooler
Reply With Quote Quick reply to this message
  #3  
Old 03-23-2012, 04:27 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 1,540
Thanks: 0
Thanked 16 Times in 16 Posts
Feedback Score: 0 reviews
It could be from the oil cooler or the High Pressure Oil Rail End Plug (there is one on each end of each cylinder head ... so 4 total for an engine). They are common leakers.

Oil Rail End Plugs (large plugs at each end of heads; incl. O-rings, use LOCTITE #11747 to seal threads)
(Ford) Same number as International
(International) 1827535C94

Cheers!
Reply With Quote Quick reply to this message
  #4  
Old 03-23-2012, 04:30 PM
Powerstroke.org Rookie
 

Join Date: Apr 2011
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Good call on the oil plugs totally blanked on that one!!!
Reply With Quote Quick reply to this message
  #5  
Old 03-23-2012, 04:31 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,007
Thanks: 0
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
In the 7.3 section there is a thread of common leak points. I'd read up.
Reply With Quote Quick reply to this message
  #6  
Old 04-03-2012, 05:10 PM
Member
 

Join Date: Feb 2012
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I figured it out. Theres a crack in the front case. Its under that ear where the top cover bolts on, made it worse by replacing the top cover gasket.. gonna pull the motor and tig weld the crack up!!!! thanks for the input.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:06 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors