95 running rough - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-10-2012, 04:01 PM Thread Starter
Powerstroke.org Rookie
Join Date: Mar 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
95 running rough

Ok, I had a no start, changed cps, and fuel pump was leaking from weep hole, changed it out, bled as much as i could, got it running idled fine about 20 min took it for a 15 mile run ran good until was aprox 2 miles from home started running rough then pulled in drive way it died, Will start and run on wd-40 but dies as soon as you quit spraying, not sure were to look now, thought about the filter in the tank but has two tanks and doesnt matter wich tank im on still same result, any help will be apreciated
plumberman is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome