97 OBS No Power/Long start - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-02-2012, 12:47 PM Thread Starter
Powerstroke.org Rookie
Join Date: Jan 2012
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
97 OBS No Power/Long start

I have a 97 OBS and have had this trouble before and traced to the Fuel Ignition management computer (I think that is the technical term) I have replaced it 4 times before. (Chinese made POS) Start up takes longer and longer and now it has gone into "Limp Mode" very little power but enough to get back to the garage. Wondering if anyone else had this problem and maybe knows a deeper root cause than the computer or where it could be repaired vs. buying a new one for $1000
WestsideFD is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome