Could Really Use Some Help!! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-07-2012, 02:33 PM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Could Really Use Some Help!!

I have a 1995 E350 with 135K I bought this van about 3 months ago with 123K. When I bought it it seemed to run pretty well. I tow a 12x6 enclosed trailer with maybe 2K in it. I prob have 3500 lbs total weight with trailer and stuff inside van.

About 3 weeks ago I had some problems when I got done working. In the morning when I went to my job the van was running good. 8 hours later it had a noticeable loss of power and it seemed like it was running on its last leg. I was changing high ways and I got on and hit about 70 mph. Right when I hit 70 the motor just completely lost power and I couldn't accelerate any more. I pulled over to the shoulder and right before I stopped the motor died. (It felt like I ran out of fuel) The van started right back up and ran fine.

About an hour later I went to drive it again and it was running rough again. So I've put like 1000 miles on it has run 'somewhat' ok. When the trailer isn't on it runs pretty good and I get about 18-20 mpg. With the trailer at 3500 lbs I get about 11 mpg. Is this average? I bought the van with the hopes of getting about 15 mpg. Anyways tonight it is running pretty bad and it feels like its going to just crap out on me any minute. Also I was going up a hill and it just didn't want to seem to upshift. I was prob at like 3K and I even tried letting off the gas a little. I had to completely let of the gas and it then shifted.

Any help or pointers would be great. I changed the oil about 4K ago and I used penzoil bc I was in FL and it needed to be changed. I also changed the fuel filter about 9K ago and cleaned the FPR screen.

Thanks for any help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-07-2012, 08:55 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Houston, Tx
Posts: 512
Thanks: 1
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
Did you use any type of oil additive? Check your fuel pressure and all the wiring. Sometimes things like to become loose on these. Do you have access to any type of scan tool? Is there any excessive smoke or different color smoke coming out?

Just a few simple questions to get this going.
Reply With Quote Quick reply to this message
  #3  
Old 02-08-2012, 06:59 PM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No I didn't put an additive in-what can I use? What wires should i be checking and where is the valve to check the fuel on a van. I don't have a scan tool but when it lost complete power on the highway that day a cel light came on but autozone said there were no codes stored. No smoke except when cold in mornings.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:31 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors