Edge Evolution programmer question - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-01-2012, 04:30 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy Edge Evolution programmer question

Hi. I just bought a '95 F350 powerstroke. It had an Edge Evolution programmer on it. I was going to return the truck to stock and remove the programmer to put on another truck. I went through the process of returning it to the stock setting and it showed to be complete, but now the check engine light and wait to start light flashes and the truck is disabled. I tried to reprogram it, but it did the same thing. Now when I plug the programmer in it says "communication error". Anyone have any suggestions? Thanks!
frmmgr is offline  
post #2 of 5 Old 01-03-2012, 11:26 AM
Compression Ignition Addict
 
97bluepowerstroke's Avatar
 
Join Date: Nov 2009
Location: Wilmington Ohio
Posts: 350
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
I have a edge I use as a code reader since I got custom tunes now. Far as the light idk. But the connection I just replug and cycle the key and fixes mine.

97 f250hd 4x4 7.3l. TW 6 pos, Rosewood Stage 1 Injectors, gauges, DIY intake, 3in dp ti 5in exhaust, D66 turbo.. More to come
97bluepowerstroke is offline  
post #3 of 5 Old 01-03-2012, 11:59 AM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,210
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 79 Times in 77 Posts
Feedback Score: 0 reviews
I would give the folks at Edge a call and see what they say. Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
post #4 of 5 Old 01-03-2012, 04:32 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for your replies! I spoke with Edge and I believe we have it worked out.
frmmgr is offline  
post #5 of 5 Old 01-18-2012, 02:35 PM
Powerstroke.org Rookie
 
Daddyjustang's Avatar
 
Join Date: Jan 2012
Location: Mandeville,La.
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What was the problem? I had the exact same thing happen today except i was going from level 2 to level 3 and it never started back up. Had to get it towed home, luckily with AAA it only cost me $10. I don't think edge is open right now it is 5:34pm here.
Daddyjustang is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome