Truck Finally Died - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-29-2011, 09:36 AM Thread Starter
Member
 
jrcrane1's Avatar
 
Join Date: Nov 2008
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Unhappy Truck Finally Died

Well I was on my way home from work and it just flat quit with no warning. Restarted several times to get it turned around on the highway and limped back to town after about 5 or six restarts and feathering the pedal. Parked and took the business van home. 2 days later on first day off tried to start but no go. AE posted the CPS bad codes so changed with the spare, no go, bought another at dealership and still no go. Changed fuel filter(fuel was almost black(injector O rings). Tried again still no go. After about an hour of 5 degree weather( truck was plugged in though) threw myself and called my brother and he towed me to Stealership. They did the scan thing and then said that the HPOP reservoir goes empty really fast when trying to start. Now they said something about the ball check valve in the block by HPOP. I told him about the injectors and the fuel but said they are waiting for parts. I thing I am a dairy cow and am being milked. I ordered a set of sticks from Swamps but they won't be here until next week. They were closed for the holidays.....Go figure. Any Ideas? Can having a couple of blown o rings cause the reservoir to empty like that or is there something compounding tyhe problem like bad LPOP. Icp reads 3000psi at first then drops.

97 F-250 Ext Cab 4X4 Auto
298000 Miles
3" Down Pipe
4" Cat Delete Exhaust
6637 Filter Mod
Heavy Duty Stancor GPR
Baby Swamps Injectors "OMG"
jrcrane1 is offline  
post #2 of 3 Old 12-29-2011, 12:21 PM
Full A-Team Member
 
Fordman247365's Avatar
 
Join Date: Dec 2008
Location: Phillips, WI
Posts: 6,407
Thanks: 3
Thanked 5 Times in 5 Posts
Mentioned: 1 Post(s)
Quoted: 1 Post(s)
Feedback Score: 1 reviews
try a different icp? faulty IPR will ruin your day also. many things can killem dead.
IDM good?
PCM toasted?
To be honest my buddy had something similar with the dying, and it was the pcm fried

Elmo/Shane

96 F350 4x4
Everything.
And its expensive.

476,000 Miles


"100% worked for, 100% paid for"
Fordman247365 is offline  
post #3 of 3 Old 03-17-2012, 02:32 PM Thread Starter
Member
 
jrcrane1's Avatar
 
Join Date: Nov 2008
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Cool Truck is running.

The check valve and ball replacement worked. Also had the Baby Swamps installed and all I can say is "WOW". They made a world of difference. Better low end and runs smoother than when I first bought the truck. Mechanic even comented on how smooth it runs and even asked where I got em. Good PR for Swamps diesel. Anyway truck still acts like power is not there on top end. I can hear the whine from the turbo an fins and end play are good. Any suggestions?

97 F-250 Ext Cab 4X4 Auto
298000 Miles
3" Down Pipe
4" Cat Delete Exhaust
6637 Filter Mod
Heavy Duty Stancor GPR
Baby Swamps Injectors "OMG"
jrcrane1 is offline  
Reply

Tags
hpop , injector o rings , no start

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome