2000 7.3 miss and BAD fuel mileage HELP PLEASE - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-26-2011, 06:27 PM Thread Starter
Powerstroke.org Rookie
Join Date: Aug 2011
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Red face 2000 7.3 miss and BAD fuel mileage HELP PLEASE

I'm new to this site and thank anyone for there insite with the follow problem. I have a 2000 F250 4X4 7.3 290k 4" lift on 35x12.50 tires it does have an edge eveloution chip. it's getting terrible fuel mileage 12mpg around town and around the same on the highway. I have resealed the injectors, replaced the ipc, repaired leak in the Map sensor line. I pull 22 lbs of boost @ full load. I've done a cyl cut out test and a buzz test passed both. However a few injectors poped up with the cct but the truck was @ 150 degrees when we ran the test. I'm leaning towards a new set of injectors, i have an occasional miss that comes and goes. But at no time do i get diesel in the oil nor does the truck smoke (other than black upon accleration). Can a bad injector or two cause poor fuel mileage? Shouldnt I see some smoke or be making oil??? PLEASE HELP IM AT MY WITS END....
runwhatubring is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome