glow plugs or relay?? - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-12-2011, 01:41 PM Thread Starter Rookie
Join Date: Jun 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
glow plugs or relay??


since a week or so my truck wont start right up in the morning.
i have to try it like 6 or 7 times.
I tried plugging the block heater in, and when i do that is starts right up as usual.

I was thinking that my glow plugs have gone bad, but i read something aboud that relay.

how can i test wich one is causing the trouble??

huub is offline  
post #2 of 3 Old 10-12-2011, 02:25 PM
Compression Ignition Addict
Patrick Feeley's Avatar
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,226
Thanks: 0
Thanked 86 Times in 84 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
Grab a DVOM (DIgital Volt Ohm Meter). Measure the voltage drop across the GP Relay by placing the meter leads on each Large relay terminal when the glowplugs are active (you have about 1.5 to 2 minutes after the key is turned to wait to start). If the reading is 0.5 volts or higher the relay is toast. I like the Stancor 586-902 relay for a replacement. It will fit, no problem and you'll probably never have to get another one. Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
post #3 of 3 Old 10-15-2011, 08:37 AM Thread Starter Rookie
Join Date: Jun 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews


i tried what you said and the relay was broken.
i put in the new one and tested that one to make sure and it is fine.
saved me some work, i was planning to just replace the glow plugs.
happy that i didn't.
huub is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome