CPS problem? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-23-2011, 03:08 PM Thread Starter
Powerstroke.org Rookie
Join Date: Feb 2011
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
CPS problem?

Hey yall I'm having a problem with my 95 f250, driving down the road the truck seems like it shuts down for just a split second then keeps chugging along like nothing ever happened. Most of the time it happens while cruising. From what I've read on searches it sounds like the cps to me anyone else have an idea? It's never died at an idle or anything
ArrestMeRed04 is offline  
Sponsored Links
post #2 of 2 Old 09-26-2011, 06:00 PM
Powerstroke.org Fanatic
jasons 7.3 powerstroke's Avatar
Join Date: Jul 2011
Posts: 135
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
possibility. I would go pick one up from ford or international only. do not buy aftermarket. Then take a 10mm socket and ratchet to change out. Takes all of about 15 minutes at the most ( if your old sensor is stuck ). Then see if that fixes problem if not throw the old one you removed in glove box for future use. I always keep a spare.

96 f250 4x4 zf5 trans. 6637 air filter mod.
jasons 7.3 powerstroke is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome