ENGINE running rough, Dies, Bad IPR? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-09-2011, 12:34 PM
Compression Ignition Addict
 

Join Date: Sep 2010
Location: Northern, Ca
Posts: 5,372
Thanks: 0
Thanked 5 Times in 2 Posts
Feedback Score: 2 reviews
Exclamation ENGINE running rough, Dies, Bad IPR?

Hey guys My dads white 7.3 powerstroke is having trouble running and idling.

you start it up, Turn it on, IT idles regular for like 2 seconds then CEL comes on and ROugh rattle idle. NO POWER, and when Floored wont rev past 2000k RPM

but heres what ive done so far. My truck (black dually) is a 95 as well so i:

Swapped IDMs, Problem was still there. didnt really change at all.
Swapped ICPs, Problem was still there.
Noticed a little difference in idle Like it was idling regular for like 4 seconds this time. but then back to the ^ explained symptoms again.
Swapped CPS's, Didnt notice anything different, besides my truck has A steering assist, and its been in a massive front end collision b4.
FOUND: IPR wires to connector were touching and may have been causing a issue? I took them apart. and cut the connector replaced wires and wrapped up and reLoomed it.
didnt seem to change after i fixed the wiring.
SO im guessing its the IPR. Because this happened b4. We changed the O rings with A/C Orings and it ran fine for like 3 weeks, Till now.

So im gonna go out and replace the O rings again, see if it changes anything. If not it may be #8 injector or #6 with a leaking Seal.

Also i need to scan codes on this truck and mine. if anyone has a scanner i can borrow?? (ship it to me?, i can leave a deposit)

i also got a video of what i did. Watch it and see if you can help me out.
Thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-09-2011, 12:43 PM
Compression Ignition Addict
 

Join Date: Sep 2010
Location: Northern, Ca
Posts: 5,372
Thanks: 0
Thanked 5 Times in 2 Posts
Feedback Score: 2 reviews
I just had a Brain fart, Theres oil in the valley. and if the seal is leaking then its the IPR. Ill replace and let you no!
Reply With Quote Quick reply to this message
  #3  
Old 09-10-2011, 08:02 PM
Compression Ignition Addict
 

Join Date: Sep 2010
Location: Northern, Ca
Posts: 5,372
Thanks: 0
Thanked 5 Times in 2 Posts
Feedback Score: 2 reviews
Wasnt it
Reply With Quote Quick reply to this message
  #4  
Old 09-11-2011, 06:56 AM
Compression Ignition Addict
 

Join Date: Jan 2010
Location: unvrhrdofit, SK
Posts: 6,528
Thanks: 0
Thanked 22 Times in 21 Posts
Feedback Score: 0 reviews
You have pretty much tried everything you can externally. The IPR o-rings didn't do it?

Do you have the means to check fuel and oil pressure?

I think you are on the right track with pulling the valve covers and diving in as your next step. Maybe the UVCH or injector rings as you mentioned.

Is it a standard trans or auto?

Reason I ask is mine was doing bizarre inconsistent rough idle, lack of power shannanigans and I went through ALL the same stuff you are going through. In the end it turned out my dual mass flywheel had about a 1/2 - 3/4" of play in it...which I thought was sort of normal. Went to a solid flywheel and away went all my problems. Just something to keep in mind and you might want to pull the inspection cover it it's a ZF5 and have a little look see.
Reply With Quote Quick reply to this message
  #5  
Old 09-11-2011, 01:12 PM
Compression Ignition Addict
 

Join Date: Sep 2010
Location: Northern, Ca
Posts: 5,372
Thanks: 0
Thanked 5 Times in 2 Posts
Feedback Score: 2 reviews
Yeah I no. I need a scanner can't find one. I'm gonna test the lift pump then well see
Reply With Quote Quick reply to this message
  #6  
Old 09-12-2011, 05:33 AM
Chapter Director
 

Join Date: Feb 2010
Location: Vacaville, CA
Posts: 2,203
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It's the uvc harness. Mine did the same thing that's why I replaced all the parts either get a shim or look up the 50 cent mod
Reply With Quote Quick reply to this message
  #7  
Old 09-12-2011, 06:56 AM
Chapter Director
 

Join Date: Feb 2010
Location: Vacaville, CA
Posts: 2,203
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Also if the The ipr made the problem worse it's because it was actually improving oil flow to the injectors but the electrical can't keep making the injectors operate right which is why I say the UVc harness.
Reply With Quote Quick reply to this message
  #8  
Old 09-12-2011, 06:03 PM
Compression Ignition Addict
 

Join Date: Sep 2010
Location: Northern, Ca
Posts: 5,372
Thanks: 0
Thanked 5 Times in 2 Posts
Feedback Score: 2 reviews
Well i dont want to just throw parts at it, Im gonna install the origanal one back in it.

My dad bought those ones from you, though us.

And hes short on cash, so You said we can return them if it didnt work.
So on our aggreement we can do that.

Thanks man.
Reply With Quote Quick reply to this message
  #9  
Old 09-12-2011, 06:26 PM
Banned

 

Join Date: Jul 2008
Location: Bryan/College Station/Tyler, TEXAS
Posts: 26,356
Thanks: 8
Thanked 6 Times in 5 Posts
Feedback Score: 1 reviews
Two things,,,,, not getting hpo or fuel.

Last edited by Jarrod B; 09-12-2011 at 06:30 PM.
Reply With Quote Quick reply to this message
  #10  
Old 09-12-2011, 06:28 PM
Compression Ignition Addict
 

Join Date: Sep 2010
Location: Northern, Ca
Posts: 5,372
Thanks: 0
Thanked 5 Times in 2 Posts
Feedback Score: 2 reviews
Im gonna check the HPOP pressure, and Pour Fuel in it soon.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:41 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors