runs good when cold, lopes when warm - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-27-2011, 10:19 AM Thread Starter Rookie
Join Date: Jul 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
runs good when cold, lopes when warm

sup guys, i have a 97 chassis cab 7.3 powerstroke with an e40d behind it. So from when i first got the truck its allways run odd, i tried changing the CPS sensor twice, once to the updated grey colored one, and now to the dark blue with purple o-ring style. My problem is that the truck starts and runs fine when cold (like dead cold) idles perfectly when cold, but as soon as it gets up to temp it starts to lope real bad and feels like its missing on 2 cylinders. Ive allready changed the fuel filter, but where is the fuel "regulator" at on these trucks?

Any help is appriciated.
cervan is offline  
post #2 of 2 Old 08-27-2011, 01:15 PM
Premium Member
bondsman's Avatar
Join Date: Apr 2008
Location: Moyock, NC
Posts: 1,273
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The fuel pressure regulator is on the driver's side of the fuel bowl. You will see you unscrew the whole assembly to gain access to the screen.
You might be suffering from a bad oring on the ipr.

05 F250 4x4 CC, 9.5" Rize/Icon, 38" Toyos, 20x12 Pacers, 5" MBRP, AFE stage 2, Cass 190s, Powermax, ELC w/filter, RCD EGR delete
04 Excursion 4x4, vacation bus
Project 1979 F250 6.0 powered in progress

bondsman is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome