engine bogs down when cold - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-23-2011, 04:15 PM Thread Starter
Join Date: Jun 2009
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
engine bogs down when cold

97 DI PSTD, F350 CC LB 4x4. When you first take off with the engine cold, the truck will lose power to the point of stopping in the road. After you stop for a minute or 2 it will suddenly come back and take off again. it will do this 3 or 4 times, each time a little less severe. After that it will pull itself ok, but you can tell it's missing out fairly bad. After doing some research on here, it sounds like the UVCH may be the culprit and I think I have some to put on when I replace the glow plugs. But I haven't seen anything about the bogging and coming back thing with the UVCH, that appears to simply cause a poor idle or dying. I have the valve cover gasket harness, is that the UVCH, or is the UVCH another wiring harness altogether? Is there a temp sender on a 97 DI PSTD? I can see that being a problem, if my truck as one. Any other ideas? I'm learning this diesel thing, but it's quite a process.


97 F350 7.3 PSD CC 4X4
nepatternmaker is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome