intermittent low power - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-02-2011, 04:02 PM
Powerstroke.org Rookie
 

Join Date: Mar 2009
Location: roanoke, va
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
intermittent low power

whats up guys, been a little while. got myself in a predicament with my truck and i need some ideas. anything would help!

it's a highly modded 95 7.3, recently built E4OD. having power problems...mainly when i go to pull a hill, or really just when i get on the gas maybe over half throttle, this thing seems to fall flat on it's face, seems like no throttle response, and i feel the engine missing. doesnt do it all the time and it doesnt seem related to how much wieght it's pulling. i cant find any predictable pattern. boost is good, fuel pressure is good, IDM is good and i've ohmed out the harnesses and replaced the UVC harnesses. it passed a cyl contribution test, hot and cold. just changed the oil. no codes present and dont see anything out of the oridnary on the live data while it was actually acting up---but i cant get to everything, just got a matco scanner. i don't have an ocilliscope to check the CMP, but i know some motors had problems with them. and i know the acc pedals were known for going bad. but i haven't found any issues with the pedal. any other ideas?

gonna change the fuel filter tommorrow...and keep up the visual checks. intermittent problems suck. trying to fix computerized trucks without proper scan tools....sucks.

anybody else come across something like this???
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-03-2011, 10:20 AM
Powerstroke.org Rookie
 

Join Date: Mar 2009
Location: roanoke, va
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Battery terminals just cleaned. Still waitin on the fuel filter. Should be here today. No codes and passes all functional tests. Think its mechanical....hopefully the fuel filter will help.
Reply With Quote Quick reply to this message
  #3  
Old 08-03-2011, 04:38 PM
Member
 

Join Date: Mar 2011
Location: Saskatoon SK
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check your HPOP pressure. might be dying and not sending enough oil to the injectors.

but it sounds like a fuel problem to me. My buddies truck had the same problem a few months back. ended up being a plugged pickup in his tank

What mods do you have? all info helps
Reply With Quote Quick reply to this message
  #4  
Old 08-03-2011, 06:57 PM
Powerstroke.org Rookie
 

Join Date: Mar 2009
Location: roanoke, va
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fuel filter did it. Power came back immediately! Must've got a bad batch of fuel or something. Interesting the filter was gray and slimy. Most nasty diesel fuel filters i've seen get black. Whats with the gray ****? Should i drop the tank/s?

Power complaint solved gentleman. Thanks for the discussion. Always helps.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:00 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors