A lot of black smoke and no power - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-08-2011, 05:56 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2010
Location: crawfordsville in
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Question A lot of black smoke and no power

My truck started acting kind of funny yesterday but it was only for a couple minutes. It was running fine then I stopped then took off then it started pouring black smoke and it sounded like a semi jay braking. I checked my gauges and everything was fine besides that I didn't have boost. I thought my turbo burnt up but now it's working fine. Kind of confused any help or advice would be great. Thanks
Hasman96 is offline  
post #2 of 2 Old 05-08-2011, 05:25 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2010
Location: crawfordsville in
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Anyone have any clue
Hasman96 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome