blows white smoke - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 04-28-2011, 08:04 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2011
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
blows white smoke

After 2000rpm if im going down a hill seems like the fuel is pooling up in the cylinders and then when i go to give it fuel again going up the hill a huge plume of white smoke comes out and the motor bogs down what could this be?
stang0303 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-07-2011, 05:26 PM
Powerstroke.org Rookie
 
Join Date: Dec 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine has about this same problem.
Any help would be great....
dave_k96 is offline  
post #3 of 4 Old 05-07-2011, 05:52 PM
Powerstroke.org Fanatic
 
top dollar's Avatar
 
Join Date: Apr 2010
Location: new florance Pa
Posts: 138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
white smoke is not fuel . it sounds like either lack of fuel or coolant burning

190cc injectors,air dog150, stage II fuel supply, custom turbo , SCT X3 tuned by eric at innovative , afe cold air intake ,zoodad, arp studs, snow meth.injection, 5in straight pipes to 8in stacks, innovative uppipe, triple pod with glow shift, remote oil cooler and filters, sinister egr delete , all by myself with cab on , never do it again!!!! and alot of good info from org
top dollar is offline  
post #4 of 4 Old 05-07-2011, 06:12 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2011
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok seems more lack of fuel then. second gear it does it the worse third gear it'll power through it fine. Doesn't seem to be using up any coolant and the coolant is clean when i check it.
stang0303 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome