7.3 won't start after oring r&r in HPOP - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-12-2011, 01:17 PM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 won't start after oring r&r in HPOP

I just put new o-rings in my HPOP and now she won't start. Put on a new cps, wait to start light is going on, ipr isn't stuck and solenoid is good. Anybody have any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-12-2011, 06:31 PM
Powerstroke.org Fanatic
 

Join Date: Oct 2006
Posts: 125
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HPOP

Well its been 3days since i replaced the plug bottom of HPOP and truck will not
start,even when unhook sensor to fool PCM into think it has more pressure than
it has still no start. the only thing i noticed today was i am getting fuel smoke
out of intake at turbo while cranking,the sick part about it is i drove truck home
when oil leak got really bad any ideas,thanks
Reply With Quote Quick reply to this message
  #3  
Old 04-12-2011, 06:36 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: Northwest Ohio
Posts: 1,181
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sounds like you got air in system, are you getting oils press while cranking?
Reply With Quote Quick reply to this message
  #4  
Old 04-14-2011, 01:04 AM
Powerstroke.org Fanatic
 

Join Date: Oct 2006
Posts: 125
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question oil leak

Well ended up taking truck garage to run on scanner and fix,they wanted about
$1700.00,so had truck brought back home ordered HPOP. I was told there is a
anti-drain valve in 95psd,but can not find out what it entails,can someone tell me what to look for or a picture of it,thanks,also what scanners are the being
used by members keep in mind price and quality
Reply With Quote Quick reply to this message
  #5  
Old 04-14-2011, 02:24 AM
Premium Member
 

Join Date: Mar 2011
Location: AUBURNDALE, FL
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
did you prime your hpop after the oring install if not there is a plug on top remove it and fill with engine oil may have to fill 2 or 3 time but shure to reinstall plug befor you try to start it
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:19 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors