95 7.3 issues - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-29-2011, 05:59 PM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
95 7.3 issues

I have acquired a 95 f350 with the ps 7.3 in it. The truck ran great until winter when it was having a hard time starting. I replaced the glow plugs, checked the relay and everything checked out but still have a hard time starting. After the glow plugs were replaced we had a hard time getting the truck to show decent oil pressure on the gauge inside the truck (just had oil changed the same week and was great before the glow plugs were replaced)

Fast forward to this week. Today were still having the issues getting the truck started when cold however the truck seems to be missing. Really rough idle, stalling when you try to drive it, white smoke out of the tail pipe all the sudden. I tried to get the truck over to a shop but the truck would not even get out of the driveway much less across town to a good diesel shop.

The truck seems to be starving for fuel in my opinion. Any ideas on where to start.

Also I forgot to mention that the truck has no fuel leaks in the valley, is a 5 speed, 175000 on it, ran great since I got it until now. Fuel filter was replaced after this started and there was plenty of fuel in the bowl at that time. I haven't checked it since then to see if there is still is now.

Last edited by mobilewashpros; 03-29-2011 at 06:18 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-30-2011, 04:15 PM
Premium Member
 

Join Date: Apr 2008
Location: Moyock, NC
Posts: 1,263
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Cam position sensor, under valve cover harnesses (are they all seated correctly), fuel pressure regulator clean?, ipr valve good?, tin nut on ipr valve tight?, ipr pigtail not frayed?, will it run with the icp unplugged?
Reply With Quote Quick reply to this message
  #3  
Old 03-30-2011, 05:06 PM
Banned
 

Join Date: Oct 2009
Location: North Port
Posts: 920
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 3 reviews
Could be what bondsman said but 94 95 had a HPOP drainback issue aswell
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:52 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors