94 PSD rough idle - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-24-2011, 06:21 PM
Powerstroke.org Fanatic
 

Join Date: Jul 2010
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
94 PSD rough idle

My 94 has just started to idle a little rough. It kinda acts like i have an injector out but if i ile it up to around 1000 rpms it comes out of it. Driving down the road it had all the power and performance that anyone could ask for. I am stumped on what could be causing it to idle rough. Also on cold start ups like on an overnight sit it will smoke when fired up.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-26-2011, 08:00 PM
Banned
 

Join Date: Oct 2009
Location: North Port
Posts: 920
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 3 reviews
Stick or Auto? Also clean the screen on the FPR that may help and change the FF
Reply With Quote Quick reply to this message
  #3  
Old 07-02-2011, 08:26 PM
Powerstroke.org Rookie
 

Join Date: Jun 2007
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Any update? Mine is doing the same thing.
Reply With Quote Quick reply to this message
  #4  
Old 07-07-2011, 05:33 PM
Powerstroke.org Fanatic
 

Join Date: Jul 2010
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Have looked and gone through everything. Its the injectors. Got one missing all the time now low power. Gonna buy some stage 1s now.
Reply With Quote Quick reply to this message
  #5  
Old 07-07-2011, 05:59 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: Coastal NECKVILLE
Posts: 474
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
how many miles on the oil?
Reply With Quote Quick reply to this message
  #6  
Old 07-07-2011, 06:39 PM
Powerstroke.org Fanatic
 

Join Date: Jul 2010
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
1000 miles really notice it when i step on the go pedal. ive got 187000 original miles on the truck since 94, I think i might hve a plunger stuck. i hate to drive it because i am afraid of melting a piston.
Reply With Quote Quick reply to this message
  #7  
Old 07-07-2011, 06:55 PM
Powerstroke.org Fanatic
 

Join Date: Jul 2010
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oh sorry 5 spd already deleted the dual mass.
Reply With Quote Quick reply to this message
  #8  
Old 07-08-2011, 04:44 PM
Powerstroke.org Rookie
 

Join Date: Jun 2007
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
have you already replaced the valve cover harnesses?
Reply With Quote Quick reply to this message
  #9  
Old 07-08-2011, 06:22 PM
Powerstroke.org Fanatic
 

Join Date: Jul 2010
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Have not replaced UVC's but did put in a new set of glowplugs in back in October and did check the UVC's and they checked out ok. But that was back in October. Will check them tho. Simple check overlooked.
Reply With Quote Quick reply to this message
  #10  
Old 07-08-2011, 06:36 PM
Banned
 

Join Date: Oct 2009
Location: North Port
Posts: 920
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 3 reviews
FPR screen?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:39 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors